3emanagement - Interruption de service | Service Disruption – Incident details

All systems operational

Here is the status page for 3emanagement products.
You will find updates on the status of our systems here, and a note will be posted in the event of a service interruption. Feel free to subscribe to receive real-time notifications during an outage

To contact us:

JurisEvolution & AcuminEvolution :
During business hours: support@jurisconcept.ca
For emergencies outside of business hours: 1-888-692-1050, extension 8

JurisPro, Procardex, and Pronotaire:
During business hours: supportpro@jurisconcept.ca
For emergencies outside of business hours: 844-799-2229

JuriWeb & JuriEDI :
During business hours: support@siunik.com
For emergencies outside of business hours: (450) 667-8860, extension 8

Interruption de service | Service Disruption

Resolved
Major outage
Started 4 days agoLasted about 1 hour

Affected

Lawyers

Major outage from 10:43 AM to 11:32 AM

JurisEvolution

Major outage from 10:43 AM to 11:32 AM

AcuminEvolution

Major outage from 10:43 AM to 11:32 AM

Notaries

Major outage from 10:43 AM to 11:32 AM

JurisPro

Major outage from 10:43 AM to 11:32 AM

Updates
  • Resolved
    Resolved

    We are pleased to inform you that our applications (JurisEvolution, JurisPro, and AcuminEvolution) are now back online and fully operational. We sincerely apologize for any inconvenience caused by this service disruption and thank you for your patience.

  • Identified
    Identified

    Please be advised that our applications (JurisEvolution, JurisPro, and AcuminEvolution) are currently unavailable this morning. Our technical teams are aware of the situation and are actively working to restore service as quickly as possible. We will keep you updated as the situation evolves. We apologize for any inconvenience this may cause.